Kismet Wireless

Kismet Forums

 

Posted by:samueldg
Subject:WiSpy running problem in FC3 & FC5
Date:19:00:05 17/08/2006

I have the same problem.

When I insert WiSpy into USB, dmesg:

usb 2-1: new low speed USB device using uhci_hcd and address 3
usb 2-1: configuration #1 chosen from 1 choice
hiddev96: USB HID v1.11 Device [MetaGeek Wi-Spy] on usb-0000:00:1d.1-1

I'm running wispy_curses as root and says when it runs:

Unable to claim interface 0 -- are you root?
Is something else using it (another program or the kernel HID)?

Where can I enable the needed kernel features? My ".config" file don't show me anything with:

cat /usr/src/linux | grep "DEVFS"

Any help?

Thanks


> > Hi,
> > I've downloaded the latest wispy drivers from svn.kismetwireless.net.
> >
> > On both my FC3 and FC5 boxes, the compile runs smoothly.
> >
> > "Unable to claim interface 0 --are you root?
> > Is something else using it (another program or the kernel HID)?"
>
> The kernel HID layer is grabbing it, and your kernel lacks detatch support, apparently (or something is missing in your kernel install which is confusing autoconf -- missing or nonfunctional or old headers in /usr/include/linux/usb_fs.h probably.
>
>
> > Did a lsmod and there was no module listed (take this as normal since kudzu did not run when i plugged the wispy in - should kudzu be run??)
> > Running kudzu showed the wispy detected as a keyboard and kudzu attempted to configure as such. Problem still there after this so i reversed this step and rebooted.
>
> A non-modular USB driver in the kernel is grabbing it.
>
> > Questions:
> >
> > 1. Is there a command which i can issue in a terminal (command line) to forcefully do the detach from the kernel?
>
> No, if your kernel doesn't support detatch, it doesn't support detatch. The wispy-tools code would have detatched it if it could.
>
> > 3. Is there an RPM upgrade which i can install (not full kernel upgrade, just a module upgrade) in order to enable this detach driver thingy?
>
> No. Detatching is a core part of the USB system. You need to upgrade to a modern kernel with detatch support and then rebuild the wispy-tools so that they are detatch-aware.
>
> -m


Reply to this message