Kismet Wireless

Kismet Forums

 

Posted by:jajoapajo
Subject:What I'm doing wrong with madwifi-ng ?
Date:19:41:17 07/08/2006

> Hello,
>
> I'm currently running under Gentoo 2.6.16-r6, and it's a while that I use Kismet. I've an atheros based chipset card and a Senao pcmcia card (prism).
> With the Senao, kismet works very well, but with the atheros based I have some trouble...
>
> I've the madwifi-ng drivers (0.1531.20060427), resp the madwifi-ng-tools, perfectly working. Today I dl kismet, the last version (unstable in portage).
> iwconfig gives me:
>
> wifi0 IEEE 802.11b ESSID:"XXX_my_essid_XXX"
> Mode:Managed Frequency:2.462 GHz Access Point: 00:06:25:C2:EE:FD
> Bit Rate:11 Mb/s Sensitivity=1/3
> Retry min limit:8 RTS thr:off Fragment thr:off
> Encryption key:XXXX:my_key_XXX Security mode:restricted
> Power Management:off
>
> wifi1 no wireless extensions.
>
> ath0 IEEE 802.11g ESSID:"" Nickname:"bibi"
> Mode:Managed Channel:0 Access Point: Not-Associated
> Bit Rate:0 kb/s Tx-Power:17 dBm Sensitivity=0/3
> Retry:off RTS thr:off Fragment thr:off
> Encryption key:off
> Power Management:off
> Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> Now, when I try to execute kismet, I obtain this message:
>
> [...]
> No specific sources given to be enabled, all will be enabled.
> Enabling channel hopping.
> Enabling channel splitting.
> Source 0 (AtherosG): Enabling monitor mode for madwifing_g source interface wifi0 channel 6...
> WARNING: wifi0 appears to not accept the Madwifi-NG controls. Will attempt to configure it as a standard Madwifi-old interface. If you are using madwifi-ng, be sure to set the source interface to the wifiX control interface, NOT athX
> FATAL: Unable to find private ioctl 'get_mode'
>
>
> And in my /etc/kismet.conf
>
> cat /etc/kismet.conf | grep source
> # source=sourcetype,interface,name[,initialchannel]
> source=madwifing_g,wifi0,AtherosG
> #source=hostap,wlan0,prism2source
>
> [...]
>
>
> Hum... I can easily do
>
> wlanconfig ath create wlandev wifi0 wlanmode monitor
>
> which creates me a new virtual interface (ath1) (It was simpler when it was iwconfig athX mode monitor between us ;)).
>
>
> I tried to put my card in monitor mode before running kismet, I try each interfaces one by one (changing in the kismet.conf after having done the wlanconfig command), but still doesn't work.
>
> I conclude that I was doing smth wrong...
>
> Thanks a lot ;)


also i had same problems
i have tried many time and many kind of source lines ;-)
everytime i've got just connected to the localhost, no signal , nothing detected
...
till yesterday when i have downloaded newest madwifi driver
i have just download and compile and install new driver ... and voila..everithing working fine

my line from conf file source=madwifing_g,wifi0,Madwifi-NG
hw: nc6000 compaq laptop with ar5212
02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
slack 10.2 kernel 2.6.16.18
madwifi ver. 0.9.2
Kismet 2006.04.R1

modprobe ath_pci
wlanconfig ath0 create wlandev wifi0 wlanmode sta
cd ~/.kismet
kismet -f mykismet.conf

thats all
maybe this help you


Reply to this message