Kismet Wireless

Kismet Forums


Posted by:ihatewires
Subject:AAGGGHHHH!!! how do I make it work!!!
Date:21:41:35 20/07/2006

By the subject you can probably guess that I can't get kismet up and running.

My wireless definatly works, I can use it to surf/download.

I have an intel ipw2200 and am using firmware 3.0, ieee80211-1.1.14 and ipw2200-1.1.3 and am running scientific Linux 4.0(re-compiled RHEL4.0) with kernel 2.6.15.

I have definatly compiled this kernel myself with all wireless (ieee80211 and ipw2200) options turned off. I have then installed the drivers and have definatly made sure in the ipw2200 Makefile that:

my /usr/local/etc/kismet.conf has the source line:

The wireless works for surfing but kismet doesn't work, even if I:
rmmod ipw2200
modprobe ipw2200 mode=2 //mode=2=monitor

kismet tells me:
Source 0 (eth0): Enabling monitor mode for ipw2200 source interface eth0 channel 6...
FATAL: Failed to set monitor mode: Invalid argument. This usually means your drivers either do not support monitor mode, or use a different mechanism for getting to it. Make sure you have a version of your drivers that support monitor mode, and consult the troubleshooting section of the README.

I'm confussed. Can somebody please help me out.

Reply to this message