Kismet Wireless

Kismet Forums

 

Posted by:gljimbo
Subject:Enabling GPS in WRT54G
Date:21:27:32 10/06/2006

I am having very similar issues.
The Kismet package from:
http://downloads.openwrt.org/whiterussian/packages/kismet-client_2005-08-R1-1_mipsel.ipk
http://tobe.mine.nu/software/openwrt/kismet_server.tgz

The first package not work with GPS, while replaceing the kismet_server with the one from the second link allows the GPS to work. Keep in mind I am using the same configuration file for both. I was hoping to find out that the 2005 version was indeed compiled without GPSD support, while the 2006 version wasn't, but when I try to use the:
http://kismetwireless.net/code/kismet-2006-04-R1-wrt54.tar.gz

I can not get Kismet to start. I am using an external channel hopping script which uses the WL command, and I have channel hopping disabled in the configuration for Kismet, and I have also tried it without the external channel hopping script.

It gives me the following error message:

Using alternate config file: /etc/kismet/kismet.conf
Suid priv-dropping disabled. This may not be secure.
No specific sources given to be enabled, all will be enabled.
Disabling channel hopping.
Source 0 (wrt54g): Enabling monitor mode for wrt54g source interface eth1 channel 0...
Source 0 (wrt54g): Opening wrt54g source interface eth1...
FATAL: pcap reported netlink type 1 (EN10MB) for eth1. This probably means you're not in RFMON mode or your drivers are reporting a bad value. Make sure you have the correct drivers and that entering monitor mode succeeded.


Reply to this message