Kismet Wireless

Kismet Forums

 

Posted by:goku1
Subject:Kismet discards good packets
Date:18:46:10 05/06/2006

Dutch, many thanks for your reply. Installing the latest version of Kismet solved the problem. It seems that the package in Debian (stable) didn't work fine with my card. I had checked dmesg but it didn't show any error messages. And nobody reported any problems about Kismet in Debian. So I assumed that the version I installed from 'stable' was super tested.

I downloaded the latest Kismet source from this website. I compiled it and it seems to work fine. The networks are 'correctly' listed and packets are not discarded. It's not as straight as using 'apt-get' but not too painful. Again, thanks for giving the suggestions.

David

> > Anyone knows why kismet discards all direct packets? I'm using Kismet version 2005.04.R1a. I installed it from the Debian packages in Sarge. The relevant
>
> Use a more recent version of Kismet.
>
> > The driver of my Atheros card (a TP-LINK TL-WN510) was compiled using madwifi sources. The sources were downloaded from debian.org and didn't give any error in the compilation. As the debian way, I created a .deb package using make-kpkg. ()
>
> Is that the old madwifi drivers, or what is popularly called madwifi-ng ? I'd suggest you use the latest released driver from madwifi.org (version 0.9.0 is an official release).
>
> >
> > lspci -vv (Info about my card's chipset)
> > 0000:06:00.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
> > Subsystem: Atheros Communications, Inc.: Unknown device 1052
>
> Which Atheros chipset is that card based on ? Check dmesg for output from the ath_pci module, to ensure that the driver supports that specific chipset.
>
> Dutch


Reply to this message