Kismet Wireless

Kismet Forums

 

Posted by:atomic
Subject:Belkin F5D7050 on OpensBSD (not showing any networks)
Date:18:34:16 12/05/2006

Hello,

I have a usb belkin f5d7050 802.11b/g adapter (uses the ural driver) that I am using under OpenBSD 3.9 on a newish powerbook G4 (macppc). The adapter is seemingly working just fine, as I am able to connect to different networks, both encrypted and unencrypted. I am, however, having a bit of trouble getting kismet to work properly. I'm not getting any error messages that I can tell, it just doesn't show any networks, and doesn't seem to gather any packets. I am using the version that's in the stable ports (2005.08.R1), and I also tried just fetching the package. With both, I get the same problem. I have modified the conf file for source=radiotap_bsd_b,ural0,radiotab_bsd_b (ural0 is the interface that ifconfig is reporting) and the rest is the default configuration. I did try a few tweaks here and there to try and get it to work, but still have had no success. Thinking that it might have been hopping channels to quickly, I also tried running "kismet -X -I radiotap_bsd_b:3" to make it stay on a channel with a known working access point, and still, I saw nothing. By putting the card into monitor mode "ifconfig ural0 mediaopt monitor chan 3 up" and using "tcpdump -n -i ural0 -y IEEE802_11" and "IEEE802_11_RADIO" I can see packet dumps just fine. I also tried running kismet while that was running, and still saw no packets from kismet. I don't know if this is related, or more of expected behavior, but if I try and run kismet after the card has been configured for a network, it hangs at "starting ui". If any more info is needed (dmesg, full kismet.conf, etc..) let me know. Thanks.


Reply to this message