Kismet Wireless

Kismet Forums

 

Posted by:dragorn
Subject:Sending out Probe Requests
Date:15:34:46 24/04/2006

> I know that this issue has been brought up before but I never found a real answer. Everytime I start up Kismet, I detect myself as a suspicious client sending out probe requests but never associating to a network.
>
> If I issue
> # iwconfig eth1 mode monitor
>
> then run Ethereal, I see all the traffic that I would expect from my surrounding wireless networks. If I then startup kismet, I see all kinds of Probe Responses to my network card MAC (although I never see any requests).
>
> I've tried everything that I could think of to get it to stop but nothing seems to work reliably.
>
> I don't want to just filter out my MAC, because I don't want everyone else detecting me either.
>
> I'm running kismet version 2005.04.R1 on kernel 2.6.13-15-smp with ipw3945 drivers.

Sounds like the drivers don't disable probing in monitor mode.

There is nothing Kismet can do about this, really, low-level activity like that is generally controlled by the drivers setting state when you tell them to go into monitor.

I assume you mean 2006-04-R1, and that you're using the ipw3945 type? The ipwlivetap type is a different beast altogether.

-m


Reply to this message