Kismet Wireless

Kismet Forums


Posted by:rberger
Subject:Msg: "No rule ot make target expat.o" building / installing newcore on Macintosh OS X
Date:07:04:23 17/04/2006

Don't know if this is related to being built on Mac OS X, but after successfully doing the make, when I try to install I get this error message:

gmake: *** No rule to make target `expat.o', needed by `gpsmap'. Stop.

I can build the stable release ok, (I used the exact same configure command line:

./configure --disable-viha --enable-syspcap LDFLAGS=-L/opt/local/lib CPPFLAGS=-I/opt/local/include

(all the other packages that were needed were built as darwin ports thus the extra flags pointing to where the darwin port results are, as noted, this worked fine for building the stable release of kismet)

It looks like newcore moves expat to a subdirectory but the Makefile doesn't seem to know about it. It seems that this would be a problem for all builds. So I presume I am missing something?


PS here's the last part that doesn't work in the build:

% sudo gmake suidinstall
g++ -I/opt/local/include -I/usr/local/include -Wall -g -O2 -no-cpp-precomp -g -O2 -g -O2 -Wall -c -o kis_clinetframe.o
g++ -I/opt/local/include -I/usr/local/include -Wall -g -O2 -no-cpp-precomp -g -O2 -g -O2 -Wall -c -o kis_panel_widgets.o
g++ -I/opt/local/include -I/usr/local/include -Wall -g -O2 -no-cpp-precomp -g -O2 -g -O2 -Wall -c -o kis_panel_windows.o
g++ -I/opt/local/include -I/usr/local/include -Wall -g -O2 -no-cpp-precomp -g -O2 -g -O2 -Wall -c -o kis_panel_frontend.o
g++ -I/opt/local/include -I/usr/local/include -Wall -g -O2 -no-cpp-precomp -g -O2 -g -O2 -Wall -c -o kismet_client.o
g++ -L/opt/local/lib -rdynamic -o kismet_client util.o ringbuf.o messagebus.o configfile.o getopt.o soundcontrol.o speechcontrol.o timetracker.o ipc_remote.o clinetframework.o tcpclient.o kis_clinetframe.o kis_panel_widgets.o kis_panel_windows.o kis_panel_frontend.o kismet_client.o -ldl -lpcre -lz -lstdc++ -lncurses -lpanel
powerpc-apple-darwin8-g++-4.0.1: unrecognized option '-rdynamic'
gmake: *** No rule to make target `expat.o', needed by `gpsmap'. Stop.

Reply to this message