Kismet Wireless

Kismet Forums

 

Posted by:tunlin
Subject:kismet_server only run for a couple of minutes
Date:00:22:50 31/03/2006

I make sure dhcpcd is not running. Here is what happen and it's strange.

1. As you said, run script that include (kismet_server) from a terminal and it run ok. Did not die.

2. I run the same script from cronjob and it only run for a couple of minutes and die. Did not see any message in /var/log/messages.

Can't figure out the root cause that kill kismet_server. If I can run manually I should able to run from cronjob as well. I already making sure all the path are setup correctly.

Here is the structure that I setup drone/server/client. Server and client are sitting in a machine and drone is sitting in different machine.

kismet_drone -> kismet_server <- kismet_client written in Perl to collect data


Thanks in advance for any help.

Tun


> > Hi,
> > I have a script that will do the following.
> >
> > 1. Check current "kismet_server" daemon, if found, kill "kismet_server" pid
> > 2. Re-start kismet_server
> >
> > I run that script from cronjob to run every 30 minutes. When cron job started, I can see kismet_server in my "ps" table for only a couple minutes, and then it die without any error messages. Please let me know if anyone has that kind of problem or a way to trouble shoot that problem.
> >
> > Thanks in advance.
>
> It won't die with no messages, you may not be looking at them, but they're there. Even if the message is the rather useless 'segfault'.
>
> A common culprit is dhcpcd. Make sure it isn't running.
>
> Run kismet_server in a terminal and wait for it to exit and see what the reason is.
>
> If it's actually consistently segfaulting, PLEASE run it under gdb (gdb ./kismet_server) and then send me the crash and the backtrace (whatever it says when it dies, followed by the output of the command 'bt')
>
> -m


Reply to this message