Kismet Wireless

Kismet Forums

 

Posted by:click
Subject:wispy_gtk on OSX: fixed!
Date:02:47:51 24/03/2006

wispy_gtk build 1795 is working for me on OSX 10.4.5 using the gtk+-2.0 packages from fink and libusb packages from fink, as well. it compiles right up and runs (which previous builds did not), nice!

thanks SO much, MIke!

J

> I too am getting the "wispy_gtk: Send error on IPC to gui: No buffer space available" error with build 1794 of wispy_gtk. I have tried the fink and pkg installers of libusb. (it was mentioned earlier in the thread that this could make a difference) I've also tried GTK+OSX (gave up on that) and am now using the GTK2 and libusb fink installs, which seem to work fine. I have the gtk-demo program up and running, so I feel like I must be pretty close here. I'm also wondering what TheDude is doing differently! Any suggestions as to how to address the "no buffer space available" issue with wispy_gtk would be greatly appreciated.
> click
>
> > Hm... I'm still getting the error with a fresh copy of SVN revision 1794. The other tools remain working just fine. I wonder what the differences in build environments are between me and TheDude...
> >
> > > > You wouldn't mind a quick explanation for what you did to get the wispy tools to compile on OS X, would you? With the last few SVN revisions, I've managed to get everything to compile and run cleanly, with the exception of wispy_gtk. While the other tools have worked just fine, the GTK version has been pretty consistent about dumping out with a:
> > > >
> > > > wispy_gtk: Send error on IPC to gui: No buffer space available
> > > >
> > >
> > > Thats what this fixes.
> > >
> > > -m


Reply to this message