Kismet Wireless

Kismet Forums

 

Posted by:Phylum
Subject:Kismet will not start: getpwuid() failed error (on Gentoo)
Date:15:07:50 21/03/2006

Good Morning...
Thanks for taking a moment to read this. I just finished reading http://www.kismetwireless.net/Forum/General/Messages/1135526572.0183139 and I'm still stuck.

Fairly new Linux user here and I'm working with Gentoo 2.6.12. I emerged kismet (maybe that was my problem?) and everything appears to be in order however kismet does not run. I went through kismet.conf (using the information ont he documentation page) and kismet_ui.conf then tried to run it but received the `could not explode home directory path, getpwuid() failed` error.

Running `/usr/X11R6/bin/kismet` results in:
Server options: none
Client options: none
Starting Server...
Waiting for server to start before starting UI...
Will drop privs to <user> (uid-N) gid N
No specific sources given to be enabled, all will be enabled.
Enable channel hopping.
Enable channel splitting.
...
...
Dropped prives to <user> (uid-N) gid N
Allowing clients to fetch WEP keys.
ERROR: Could not explode home directory path, getpwuid() failed.

I ran this in / then switched to the specified <user> home directory (i.e.: /home/<user>). I also edited the `logtemplate` directive specifying the full path (i.e.: /home/<user>/netlogs/...) with no change at all.

Permissions for my /etc/passwd: -rw-r--r-- 1 root root size date /etc/passwd

Just so you know, I'm logged into X as a regular user, opened a term and `su -`'d to root in order to configure and run kismet (conf file: /etc/kismet.conf).

Any help would greatly be appreciated.

J


Reply to this message