Kismet Wireless

Kismet Forums

 

Posted by:Bert
Subject:Error when I run Kismet on Fedora Core 4
Date:00:01:43 05/03/2006

I think madwifi_ng driver is only supported in Kismet-newcore.

I use madwifi-cvs-20050814 and it works great for my card (Proxim b/g combo pcmcia card 8470-WD i think) and kismet

Just noticed madwifi.sf.net have released madwifi-old-current.tar.gz - 28-Jan-2006 so will let you know how i get on with it.


> my kernel is 2.6.15-1.1831_FC4
> my wifi card is orinocco pci. It seems atheros driver is ok, so :
> I installed madwifi_ng drivers ( version r1311-20051108 or r1418-20060131 ) : OK
> I compiled/installed/configured kismet( stable version ) : OK
>
> When i run kismet, this fatal error happens ( with each version of madwifi ) :
>
> Server options: none
> Client options: none
> Starting server...
> Waiting for server to start before starting UI...
> Will drop privs to tedesco (500) gid 500
> No specific sources given to be enabled, all will be enabled.
> Enabling channel hopping.
> Enabling channel splitting.
> Source 0 (addme): Enabling monitor mode for madwifi_g source interface ath0 channel 2...
> FATAL: Failed to retrieve list of private ioctls 7:Argument list too long
>
> what do you think about this ? anyone's idea ?
>
> Thanks a lot.


Reply to this message