Kismet Wireless

Kismet Forums

 

Posted by:Elhanan
Subject:channel hopping for minutes interval?
Date:16:34:32 20/02/2017

here's the thing i've configured kismet to stay on channel 9 where it should not get a message from a wifi device, in order to test the hopping and dell, but the problem i'm still getting message:

16:29:44.975613 1.0 Mb/s 2452 MHz 11b -45dB signal antenna 1 0us 01:0c:cc:00:00:00 (oui Unknown) SNA > 00:0c:cc:71:70:14 (oui Unknown) STP Information, send seq 0, rcv seq 32, Flags [Final], length 1

kismet is running on a raspberry pi with a wi-fi usb dongle.
> > > > hi..
> > > >
> > > > is there a way to make kismet remain on a channel for 5 minutes, before it hops to the next?
> > > >
> > > > i'm thinking channeldwell might be the right parameter, but i can't tell from the logs, when exactly kismet hops to the next channel.
> > >
> > > An interesting question - Yeah, channeldwell should be what you want, w/ the value in seconds. So channeldwell=300 ought to stay for 5 minutes.
> >
> > but how would i know when hopped channels? is there any log message i can enable?
>
> No - normally channel hopping is several times a second, so there's nothing that logs that, it just changes the channel.
>
> As I work on the new datasource code in the git repo I'll consider adding some sort of feedback for very slow channel hopping, however.


Reply to this message