Download Documentation
kismetwireless
Forum Links


Kismet Forums
Posted by:noni
Subject:"No frames from Kismet drone server" error
Date:10:38:22 29/01/2013

Hi guys.

Since I didn't want to spend your time answering an already solved problem, I spent a good deal of time searching the web for a solution to my problem. After failing to solve it, I decided to ask for your help. I'm a LINUX newbie, but with a big desire to learn more.

I'm trying to make Kismet drone work on a Ubiquiti NanoStation 5 device. I'm using OpenWRT distribution (Backfire 10.03 version) and kismet-drone_2009-06-R1 version. (I have to tell that using a newer distribution of OpenWRT is out of question because my device has showed significant problems with them.)
Here is the kismet_drone.conf file:

# Kismet drone config file

version=newcore.1

# Name of drone server (informational)
servername=Kismet-Drone

# Drone configuration
# Protocol, interface, and port to listen on
dronelisten=tcp://0.0.0.0:2502
# Hosts allowed to connect, comma separated. May include netmasks.
# allowedhosts=127.0.0.1,10.10.10.0/255.255.255.0
droneallowedhosts=192.168.1.0/24
# Maximum number of drone clients
dronemaxclients=10
droneringlen=65535

# Do we have a GPS?
gps=false
# Do we use a locally serial attached GPS, or use a gpsd server?
# (Pick only one)
gpstype=gpsd
# gpstype=serial
# What serial device do we look for the GPS on?
gpsdevice=/dev/rfcomm0
# Host:port that GPSD is running on. This can be localhost OR remote!
gpshost=localhost:2947
# Do we lock the mode? This overrides coordinates of lock "0", which will
# generate some bad information until you get a GPS lock, but it will
# fix problems with GPS units with broken NMEA that report lock 0
gpsmodelock=false
# Do we try to reconnect if we lose our link to the GPS, or do we just
# let it die and be disabled?
gpsreconnect=true

# See the README for full information on the new source format
# ncsource=interface:options
ncsource=ath0:type=madwifi
# for example:
# ncsource=wlan0
# ncsource=wifi0:type=madwifi
# ncsource=wlan0:name=intel,hop=false,channel=11

# Special per-source options
# sourceopts=[sourcename|*]:opt1,opt2
# sourceopts=*:fuzzycrypt,weakvalidate

# Comma-separated list of sources to enable, if you don't want to enable all
# the sources you defined.
# Comma-separated list of sources to enable, if you don't want to enable all
# the sources you defined.
# enablesource=source1,source2

# How many channels per second do we hop? (1-10)
channelvelocity=5

# By setting the dwell time for channel hopping we override the channelvelocity
# setting above and dwell on each channel for the given number of seconds.
#channeldwell=10

# Users outside the US might want to use this list:
# channellist=IEEE80211b:1,7,13,2,8,3,14,9,4,10,5,11,6,12
channellist=IEEE80211b:1:3,6:3,11:3,2,7,3,8,4,9,5,10

# US IEEE 80211a
channellist=IEEE80211a:36,40,44,48,52,56,60,64,149,153,157,161,165

# Combo
channellist=IEEE80211ab:1:3,6:3,11:3,2,7,3,8,4,9,5,10,36,40,44,48,52,56,60,64,1$

.........

After executing kismet_drone command, I get the following:

root@OpenWrt:~# kismet_drone
ERROR: NOT spawning suid-root IPC capture control, beca
running as root. This is not the preferred meth
because it prevents certain security features fr
INFO: Reading from config file /etc/kismet/kismet_drone
INFO: Plugin system disabled by Kismet configuration fi
INFO: Setting drone connection buffer to 65535 bytes
INFO: Kismet will attempt to hop channels at 5 channels
overridden by source-specific options
INFO: No specific sources named on the command line, so
kismet.conf
INFO: Using hardware channel list 36,40,42,44,48,5250,5
,157,160,161,165, 18 channels on source ath0
INFO: Source 'ath0' will attempt to create and use a mo
of reconfiguring the main interface
INFO: Created source ath0 with UUID 9b4bc95e-4124-11df-
INFO: Will attempt to reopen on source 'ath0' if there
INFO: Created Kismet drone TCP server on port 2502
INFO: Starting GPS components...
INFO: GPS support disabled in kismet.conf
INFO: Kismet drone starting to gather packets
INFO: Madwifi source ath0: Found monitor-mode VAP ath0:
instead of making a new one.
ERROR: Source 'ath0' doesn't have mac80211 support, disabling
default monitor mode VAP
INFO: Interface 'ath0' is already marked as being in mo
as it is.
INFO: Started source 'ath0'

.........

Assuming that drone is working ok, I start a kismet server on Backtrack 4.
Here is the most important configuration for kismet.conf file that I changed:

....
ncsource=drone:host=192.168.1.70,port=2502
....

After executing kismet_server command I get the following:

root@bt:~# kismet_server
ERROR: Kismet was started as root, NOT launching external control binary.
This is NOT the preferred method of starting Kismet as Kismet will
continue to run as root the entire time. Please read the README
file section about Installation & Security and be sure this is what
you want to do.
INFO: Reading from config file /usr/etc/kismet.conf
INFO: Plugin system disabled by Kismet configuration file or command line
INFO: No 'dronelisten' config line and no command line drone-listen
argument given, Kismet drone server will not be enabled.
INFO: Created alert tracker...
INFO: Kismet will attempt to hop channels at 5 channels per second unless
overridden by source-specific options
INFO: No specific sources named on the command line, sources will be read
from kismet.conf
INFO: Matched source type 'drone' for auto-type source 'drone'
INFO: Using default channel list 'n/a' on source 'drone'
INFO: Created source drone with UUID d7f2bfd0-69f2-11e2-8456-30040c171802
INFO: Disabling channel hopping on source 'drone' because it is not
capable of setting the channel.
INFO: Will attempt to reopen on source 'drone' if there are errors
INFO: Created Kismet UI TCP server on port 2502
INFO: Kismet drone framework disabled, drone will not be activated.
INFO: Inserting basic packet dissectors...
INFO: Allowing Kismet frontends to view WEP keys
INFO: Starting GPS components...
INFO: GPS support disabled in kismet.conf
ERROR: Could not open OUI file '/etc/manuf': No such file or directory
ERROR: Could not open OUI file '/usr/share/wireshark/wireshark/manuf': No
such file or directory
INFO: Opened OUI file '/usr/share/wireshark/manuf
INFO: Indexing manufacturer db
INFO: Completed indexing manufacturer db, 17600 lines 352 indexes
INFO: Creating network tracker...
ERROR: Kismet was not compiled with PCRE, cannot use 'ssidregex' option in
an apspoof filter
INFO: Creating channel tracker...
INFO: Registering dumpfiles...
INFO: Pcap log in PPI format
INFO: Opened pcapdump log file 'Kismet-20130129-04-04-10-1.pcapdump'
INFO: Opened netxml log file 'Kismet-20130129-04-04-10-1.netxml'
INFO: Opened nettxt log file 'Kismet-20130129-04-04-10-1.nettxt'
INFO: Opened gpsxml log file 'Kismet-20130129-04-04-10-1.gpsxml'
INFO: Opened alert log file 'Kismet-20130129-04-04-10-1.alert'
INFO: Kismet starting to gather packets
INFO: Started source 'drone'
INFO: Kismet drone client connected to remote server "Kismet-Drone" using
protocol version 1
ERROR: No frames from Kismet drone server at 192.168.1.70:2502 in 20
seconds, disconnecting
INFO: Reconnected to Kismet drone server at 192.168.1.70:2502
INFO: Kismet drone client connected to remote server "Kismet-Drone" using
protocol version 1
ERROR: No frames from Kismet drone server at 192.168.1.70:2502 in 20
seconds, disconnecting
INFO: Reconnected to Kismet drone server at 192.168.1.70:2502
INFO: Kismet drone client connected to remote server "Kismet-Drone" using
protocol version 1
ERROR: DRONE(Kismet-Drone) - TCP server client read() ended for
192.168.1.70
ERROR: No frames from Kismet drone server at 192.168.1.70:2502 in 20
seconds, disconnecting

....
Also the drone reacts after kismet_server command and gives the following:

ERROR: TCP server client read() ended for 192.168.1.70
ERROR: TCP server client read() ended for 192.168.1.70
ERROR: TCP server client read() ended for 192.168.1.70


So, it seems that the kismet server is communicating with the drone, but something else is not working. (I have to remember you that my NanoStation 5 can pick only 5 GHz networks and maybe no such network exists in my area!)

Thanks in advance!


Reply to this message



dragorn@kismetwireless.net